Author Topic: Initial Analysis is taking HOURS. Is this normal  (Read 22458 times)

Offline taliwalt

  • Newbie
  • *
  • Posts: 1
    • View Profile
Initial Analysis is taking HOURS. Is this normal
« on: September 09, 2006, 07:45:09 pm »
Hi I'm a new zsoft user and I can't wait to put zsoft to work. But I have a problem. I installed ZSoft last night at around 10pm. It's now almost sixteen hours later and the analysis is only half done!  Is this normal? If I end it will it pick up where it left off?  ???

Offline Admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 522
    • View Profile
    • ZSoft Software
Re: Initial Analysis is taking HOURS. Is this normal
« Reply #1 on: September 18, 2006, 04:51:47 pm »
Some people are having problems that for some reason results in the analysis never completing... I myself have never encountered this, so it is very hard for me to debug...

I'll send you a PM with the link to a debug version, in case you are interested in helping out :)

Offline Stevie

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Initial Analysis is taking HOURS. Is this normal
« Reply #2 on: September 18, 2006, 06:10:57 pm »
it doesnt take hours here but it surely takes some time.
this is a very funny behaviour tho, which EVERY uninstaller program has that i tried yet.
when analyizing the registry and the folders for the first time it takes about 2 - 5 mins here.
when doing it again the analyze process is much faster. maybe the program changes the date of
all the files in the ntfs file system and can therefore do it much faster the 2nd time.
but maybe im also writing bullshit :)

Offline Admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 522
    • View Profile
    • ZSoft Software
Re: Initial Analysis is taking HOURS. Is this normal
« Reply #3 on: September 18, 2006, 08:31:08 pm »
I believe, not sure though, that it is because that XP catches the data somehow... If you make a search using the build-in function in XP it is also way faster the second time :)

Offline Stevie

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Initial Analysis is taking HOURS. Is this normal
« Reply #4 on: September 20, 2006, 07:27:28 pm »
yeah maybe some internal XP stuff. some database that is updated.

me too when analyze

  • Guest
Re: Initial Analysis before install is taking HOURS. Is this normal
« Reply #5 on: October 01, 2006, 01:43:31 am »
Initial Analysis  before install is taking HOURS. Is this normal

v231 hang.  files (47513) and reg (273466) quits counting; clock never stops, have to kill with taskman with only c: selected, is 36GB drive raptor.  Selected other drives with c: also to see if count rises; reg stays same, files count to 259687 still hangs, no changes, clock counts 4ever, have to kill.  When hung? uses 25 to 30MB RAM w/no change after file/reg count stops, zero CPU when hung?

has worked a few times at first now wont at all.

zsoft, thanks for the product, not complaining just hoping you can see a trend and or help me fix it so I can stop my search for a uninstaller... 

AMD OPT 170 OC to 2.6
2GB RAM
XP SP2 all patches
SAV corp 10.1
Intel Execute Disable BIT set for all EXE's
36 GB Raptor sytem
data 1 500 GB
data 2 500 GB

Will check back here for updates (email fake to protect form spambots...)
 

Offline Admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 522
    • View Profile
    • ZSoft Software
Re: Initial Analysis is taking HOURS. Is this normal
« Reply #6 on: October 01, 2006, 01:53:42 pm »
I actually didn't want to post this link 'public' but suppose I have to...

Everyone having problems, please download and run this: http://www.zsoft.dk/downloads/ZSoft_Uninstaller_2.3.2.3.Beta.Debug.rar

All 'safety' stuff have been removed from the analyser code, and a debugging component have been enabled... This will probably result in a crash pretty fast, but this is what we want -- a crash, with a bug report so the bug can be fixed :)

All you have to do is run the program, try to make an analysis, and press the send-bug-report button when it crashes :).

Sander

  • Guest
Re: Initial Analysis is taking HOURS. Is this normal
« Reply #7 on: October 01, 2006, 05:32:22 pm »
Hi,

I formatted my PC this afternoon, so i have only these programs installed now:
Kaspersky v. 6.0.0.303 (i tried blocking this), utorrent, ccleaner, firefox and, naturally, zsoft uninstaller 2.3.1.
Drivers: video -> ATI , chipset -> Nvidia. All programs are the last release.
Yesterday i had the same programs (and others), but I had never this problem.

So... I tried your debug version, there isn't problem: the uninstaller finishes it's analize perfectly without crash.
But the number of "Files found" and "Reg found" are always different with the normal version.
Also the files in the directory "Logs" are different... so I think there is some basic problems with this debug version...

Offline Admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 522
    • View Profile
    • ZSoft Software
Re: Initial Analysis is taking HOURS. Is this normal
« Reply #8 on: October 01, 2006, 07:09:59 pm »
Yeah, the files in the log directory is different in the debug version as it is newer than the current released one - it has been changed (as talked about here). The analyse installation function now only scans the HKEY_LOCAL_MASHINE and HKEY_USERS part of the registry - as it turns out the rest of the registry is just 'shortcuts' to something within those two 'mainkeys' :)

So, there will be less files in the log directory in the debug version, and you cannot directly compare the files and registry entries found in the two versions as the none-debug version actually recorded some duplicates (and, (and I'm not certain here - made these changes some time ago), the debug version also might record something the none-debug doesn't)...

The number of files and registry entries found should however still be ~ the same every time in the beta version (unless of course you have done something 'wild' ;))...

Sander

  • Guest
Re: Initial Analysis is taking HOURS. Is this normal
« Reply #9 on: October 01, 2006, 07:20:14 pm »
Ok i solved the problem in my PC :)

the error was in regedit:
-------------------------------------------------------------------------
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Mozilla Firefox (1.5)]
"DisplayName"="Mozilla Firefox (1.5)"
"UninstallString"="C:\\Programmi\\Mozilla Firefox\\uninstall\\uninstall.exe /ua \"1.5 (it)\""
"DisplayIcon"="C:\\Programmi\\Mozilla Firefox\\firefox.exe,0"
"DisplayVersion"="1.5 (it)"
"Comment"="Mozilla Firefox"
"InstallLocation"="C:\\Programmi\\Mozilla Firefox"
"NoModify"=hex(4):
"NoRepair"=hex(4):
"Publisher"="Mozilla"
"URLInfoAbout"="http://www.mozilla.org/"
"URLUpdateInfo"="http://www.mozilla.org/products/firefox/"
------------------------------------------------------------------------------------------------

In the values "NoModify" and "NoRepair".

I saw in these values: "(Valore DWORD non valido)", in english something like "(DWORD value not valid)" and I solved deleting these 2 keys.

Probably with a regedit checker you could find these errors (I tried ccleaner but it didn't find), but I found them manually with the "Ignore List" in Zsoft Uninstaller.

I think you can find these errors exporting all key, like HKLM, opening this with a editor e finding the string "hex(4)". it shound be an error.

Byez and sorry for my english :P

Offline Admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 522
    • View Profile
    • ZSoft Software
Re: Initial Analysis is taking HOURS. Is this normal
« Reply #10 on: October 01, 2006, 07:36:04 pm »
That is nicely found - but the debug version worked with the values still there, right?

Sander

  • Guest
Re: Initial Analysis is taking HOURS. Is this normal
« Reply #11 on: October 01, 2006, 07:46:20 pm »
That is nicely found - but the debug version worked with the values still there, right?

Yes, right, and it's strange, no?

Offline Admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 522
    • View Profile
    • ZSoft Software
Re: Initial Analysis is taking HOURS. Is this normal
« Reply #12 on: October 01, 2006, 08:13:01 pm »
Not really... The debug version is newer than the released version, and I have found and fixed a bug in the registry-dump part of the code in the debug version compared to the released version...

I just thought that there might be more errors, but perhaps not :)

XD

  • Guest
Re: Initial Analysis is taking HOURS. Is this normal
« Reply #13 on: October 07, 2006, 03:14:25 am »
I have this problem also. I ran the analuzer last night around (10 PM) and at 10 AM it was still going. I had to close the whole program via task manager. I couldn't wait any longer. Any fix for this? Do I need to use the debugger?

Offline Admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 522
    • View Profile
    • ZSoft Software
Re: Initial Analysis is taking HOURS. Is this normal
« Reply #14 on: October 07, 2006, 12:25:09 pm »
Yeah, give the debug version a try (http://www.zsoft.dk/downloads/ZSoft_Uninstaller_2.3.2.3.Beta.Debug.rar) - if it works it's great - if it doesn't you can very easily send a bug-report :)