Author Topic: ERROR: "The parameter is incorrect."  (Read 4024 times)

Offline DesElms

  • Newbie
  • *
  • Posts: 1
    • View Profile
ERROR: "The parameter is incorrect."
« on: July 05, 2009, 12:45:31 am »
RE:  ZSoft Unistaller 2.41

And speaking of version number, as long as I've brought it up (though this isn't the point of my posting), it's terribly implortant that the version number appears, clearly, and without waiting for it to scroll past (if that happens to be where I would have found it had I waited long enough), on the   Help > About  dialog.  All software is like that... except, for some reason, ZSoft.  That version number really needs to be there.  Please, in future versions, make sure that it is.  And as long as we're on the subject of what's on that screen, please do away with the auto-scrolling credits.  It's not a TV program.  It's software.  If you want to put a list there that's longer, vertically, than there is room for, then simply put a vertical slider on the right edge.  Please... enough with the TV-like auto-scrolling credits.

But, alas, that's not my reason for posting...


I don't know if I should have put this in the "Bug Reports" area or here... and the reason is because, sure, I guess maybe I'm reporting a bug, but more than that, I'm requesting help if I can get it.  Since that's more important to me, I decided to post here.  I hope that's okay.  Anyway...

I'm using 32-bit Vista SP2 on a relatively new HP notebook that has a newly-reinstalled copy of Vista on it that is absolutely current in terms of updates/patches/hotfixes, etc.

I installed ZSoft Uninstaller as I always have; and I configured it to put small icons on the list.  I used it a few times with no problems; even did a before-and-after analysis or two.  No problems.  But today, suddenly, there's an odd error.  Basically, when I launched ZSoft Uninstaller, the main window of the program launched okay, but then, before the list of installed programs could paint onto the screen, I got a pop-up dialog containing the error message...

The parameter is incorrect.

...and there was an "OK" button at the bottom of the dialog
to dismiss it.  When I dismissed it, ZSoft just sort of stopped working with a blank little rectangular dialog hovering above what should have been the installed programs list, and it would still not scan and display the installed programs list.  It didn't freeze, mind you.  I could still click on the drop-down menus, and I could still close it altogether by clicking on the little "X" in the upper-rightmost corner.  But it wouldn't read the list of installed programs and display them; and there was that blank gray rectagle just hovering there above where the list of installed programs should have been.

I close it and re-opened it and it did it again.

Thinking that maybe one of the program files had become corrupt, I used REVO UNISTALLER to completely remove ZSoft and all of its directories, icons, etc.  Then I downloaded a fresh copy of ZSoft and re-installed it.

This time, it opened-up just find and displayed the list of installed programs, as usual.

Then I went into Settings and tried to tell ZSoft to display small icons in the list...

...and lo and behold, I suddenly got the pop-up error dialog "The parameter is incorrect" yet again.  And, again, there was an "OK" button at the bottom of the dialog so that I could dismiss it.

When I dismissed it, that gray rectangular box was hovering above the list of installed programs again, only this time, it had the words "Please stand by..." written on it.  At that point I realized that that was probably what should have been on the blank version of that same box back when I first ran into the problem on program startup.

So, then I closed the program, and re-launched it (remember that I left the checkmark next to "as small icons in the list") and, voila!, I got the very same symptom as I had when I first got it on startup, before I reinstalled it.

So, then I removed the checkmark next to "as small icons in the list" and closed it, then re-launched it.  And, voila!, no problems.

Then I tried to put a checkmark next to "as small icons in the list" and I got the error message again.

I also repeated the entire experiment with the large icons setting... and got the exact same results.

So, then, clearly, the problem is positively related to the act of trying to display any icons in the list.  

If there is no checkmark next to either of the "display xxxxx icons in the list" settings, then ZSoft opens and runs just fine with no pop-up errors.  

However, if I put a checkmark next to either of the "display xxxxx icons in the list" settings, then I either get the pop-up "The parameter is incorrect" error at the instant that I so do; or, if I do, and then leave the checkmark there and close ZSoft Uninstaller, then I get the "The Parameter is incorrect" error when next I launch it.

In either case, it clearly errors at the instant that it attempts to display the list of installed programs with either type of icon in the list.  Period.  That's the instant that it happens, whether it's after the program is opened and it tries to re-paint the list with icons in it, or as it opens and attempts to paint the list on the screen for the first time with icons in it.

Now, as I type this, it occurs to me that maybe my icon cache is corrupt... and I'll go check that after I finish typing this.  But it seems unlikely since, like I said, I just re-installed Windows on this machine, and then promptly applied both Service Packs 1 and 2, and then made sure, through Windows Update, that all other patches or hotfixes had been installed.  I did this before I even installed a single third-party application... including ZSoft Uninstaller.  It sure would be weird for the icons cache to corrupt so soon.  Plus, looking around in my system, all icons in all folders, and on the start menu, all look normal.  If the icons cache were corrupt, I'd surely have tons of blank icons.  So, honestly, I don't think that's it... but I'll go reset the cache anyway and see what happens.

Any ideas, anyone?


___________________________________
Gregg DesElms
gregg@greggdeselms.com

Offline Admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 522
    • View Profile
    • ZSoft Software
Re: ERROR: "The parameter is incorrect."
« Reply #1 on: July 14, 2009, 07:38:04 pm »
Sorry about the delay in answering...

The auto-scrolling is gone in v2.5 Beta... I'll try to remember to add the version info to the about-screen as well...

The 'The parameter is incorrect' thing... Could I get you to try the v2.5 beta (available here: http://forum.zsoft.dk/index.php?topic=166.0)? That has some debug-things build in, and will (hopefully) make it easier to find the bug... Thank you!