Post reply

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.
Message icon:

This box must be left blank:

Math question: 6+3 equals what?:

shortcuts: hit alt+s to submit/post or alt+p to preview

Topic Summary

Posted by: Janus Daniels
« on: April 20, 2010, 01:55:46 AM »

I've uninstalled a couple of programs, and ZSoft Uninstaller seems to work now.
This is a more logical title and thread for the problem we've run into at;boardseen#new
so, here's the outcome from there:
Re: windows 7 64-bit
« Reply #6 on: April 06, 2010, 03:55:02 PM »
Windows 7 Ultimate 64 bit; sometimes it works, sometimes not.
ZSoft Uninstaller > Analyze > Edit Ignore List > Add > Registry >
I'll try it for a few days and let you know.
Janus Daniels
« Reply #7 on: April 07, 2010, 04:48:09 PM »
This seems to work; in 64 bit Windows I've installed:
and all of them show under the "Analyzed Programs" tab.
Oddly, WinRAR (64 bit) does not show up under "Installed Programs" tab.
The green progress bars don't always reach the end of their rectangles, but the program seems to work.
However, I haven't uninstalled anything.
Parenthetically, I'd suggest changing the title of this thread from "windows 7 64-bit" to "Windows 64-bit" since the problem seems relevant to all 64 bit versions of Windows.
Re: windows 7 64-bit
« Reply #8 on: April 15, 2010, 03:52:39 PM »
Because ZSoft isn't yet fully compatible with 64 bits O.S.
In fact it seems that is needed to use WMI to read the installed software (64 bits):
Maybe the developer can clarify...
Posted by: Majomo
« on: October 26, 2009, 09:40:31 PM »

It seems like it's going to be ignoring a huge chunk of the registry.

Maybe not:

When using the registry API  in a 32-bit application, Wow6432Node acts like a symbolic link that loops back to the same 32-bit hive. It does not map into the 64-bit hive as you might think.

For example, walking the registry tree down to HKLM\Software\Wow6432Node in a 32-bit application loops back to HKLM\Software. The result is infinite recursion: HKLM\Software\Wow6432Node\Wow6432Node\Wow6432Node\..., etc.

If you want to view the 64-bit registry hive in 32-bit code you must open HKLM\Software using KEY_WOW64_64KEY. Do not try to open Wow6432Node; it will not work.


To be compatible with 64 bits is needed ZU to ignore 'Wow6432Node' by default perhaps? If so do we have ZU to Vista/Seven 32bits and 64bits? It will be very good.  :D
Posted by: Maji14
« on: October 26, 2009, 05:17:48 AM »

I'm having the same problem as this,201.msg1069.html#msg1069
on a Vista 64bit machine.

The suggested fix was to ignore HKLM\SOFTWARE\Wow6432Node. But  when you look at that, every program on the computer has something there! It seems like it's going to be ignoring a huge chunk of the registry.

I've tried various things, including HKLM\SOFTWARE\Wow6432Node\Wow6432Node and the shorter one above.

I've tried it a couple times, and sometimes it shows the progress bars to the right of the figures, and other times it doesn't.

Once it only took 60 seconds to finish, but on other tries before and after that it reverted back to the unending grind.

I'm ready to give up on it. Sounds like a good program to have - if it would only work. Bye.