Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Andavari

Pages: [1]
1
Bugs / Bug, lists already installed files as Added
« on: March 26, 2007, 10:35:25 PM »
I am wondering if there is a bug in ZSoft Uninstaller, here's the scenario:
1. I ran a ZSoft Uninstaller analysis, then closed the program thinking a reboot would be necessary for the software installation I was about to do.

2. I then installed Microsoft .NET Framework 3.0 (since an upcoming Paint.NET version will require it), then I rebooted.

3. As soon as Windows restarted I visited Microsoft Update and downloaded two critical updates for components installed by .NET Framework 3.0, and then I rebooted again.

4. As soon as Windows restarted I finished the ZSoft Uninstaller analysis and wondered why it was taking so long. Being curious as to how slow the final analysis took I viewed the ZSoft Uninstaller log for .NET Framework 3.0.

5. Now here's whats interesting:
I noticed the analysis log had files listed as Added which were already installed on my system therefore they shouldn't even show up in the log. Some of the files in question are all of my audio encoding and decoding software located in C:\Audio-Tools, and allot of other directories and files, etc. Since it logged those already installed files as newly added files it would delete them if I were to use ZSoft Uninstaller for uninstalling .NET Framework 3.0.


Can anyone confirm this? Here's how to do it:
1. Run ZSoft Uninstaller.

2. Click 'Analyzed Programs'.

3. Right click some installed programs, and select 'Show Recorded Info'.

I'm wondering if anyone else has files that were already installed are being deemed as newly added, and if they're are showing up in the uninstall logs.

System Specifications:
* ZSoft Uninstaller 2.3.4
* MS Windows XP SP2 (fully updated)
* AVG Antivirus Free Edition 7.5 (fully updated)

Pages: [1]